Introduction

XOn NTX Toolkit
Return to Introduction

This add-on library for LabVIEW under NT/W2K/XP enables port I/O-access, as well as memory access. Hardware access can also be realized with compatibility-VIs similar to the LabVIEW functions under Win9x.

Under Windows NT access to port-I/O is only permitted for drivers. The system allocates a certain address range for a driver. The XOn port I/O-driver allows the configuration of max 10 address ranges of variable size which can be accessed simultaneously. For the configuration of these address areas the "XOn Port I/O Manager" is shipped with the driver. Thus you can access address ranges that are normally managed by the system.


In Port

This VI allows you to read either a single bye or word from the specified register address. The value is returned, in hexadecimal format, to Value.

Connector Pane

in portc

Controls and Indicators

cu32 register address

cbool read a byte or a word (F:byte)

iu16 value


IOClose

Connector Pane

ioclosec

Controls and Indicators

cdlrn IOHandle

ibool OK?


IOOpen

Connector Pane

ioopenc

Controls and Indicators

cstr IODevice

idlrn IOHandle


IORead

Connector Pane

ioreadc

Controls and Indicators

cdlrn IOHandle

cu32 IOPort

cenum Type(Byte)

ibool OK?

iu32 Value

idlrn IOHandle/dup


IOWrite

Connector Pane

iowritec

Controls and Indicators

cdlrn IOHandle

cu32 IOPort

cu32 Value(0)

cenum Type(Byte)

ibool OK?

idlrn IOHandle/dup


Out Port

This VI allows you to write a single byte or word to the specified register address.

Connector Pane

out portc

Controls and Indicators

cu32 register address

cu16 value

cbool write a byte or a word (F:byte)


XOnNTX_Close

Closes an explicit or implicit driver handle. See XOnNTX_Open for more information.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver handle.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_GetDiagnosis

Returns diagnostic information on the last call of a driver-function.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

icclst DiagInfo
Diagnostic information type.

IoctlCode | Internal code of last called driver function
Status | Status-Code of call (0=SUCCESS)
Description | Textual description ("OK" on success)

iu32 IoctlCode
Internal code of last called driver function.

iu32 Status
Values are 32 bit values layed out as follows:
status

|
Sev

Bit 30-31
is the severity code
· 00 - Success
· 01 - Informational
· 10 - Warning
· 11 - Error

|
c

Bit 29
is the Customer code flag

|
r

Bit 28
is a reserved bit

|
Facility

Bit 16-27
is the facility code

|
Code

Bit 0-15
is the facility's status code

Define the facility codes
x2=FACILITY_RPC_RUNTIME
x3=FACILITY_RPC_STUBS
x4=FACILITY_IO_ERROR_CODE
Define the severity codes
x0=STATUS_SEVERITY_SUCCESS
x1=STATUS_SEVERITY_INFORMATIONAL
x2=STATUS_SEVERITY_WARNING
x3=STATUS_SEVERITY_ERROR

istr Description
Textual description ("OK" on success).

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_Open

Opens the NT-Extension Driver and returns a handle to it usable from other XOnNTX functions.

Thus recommended, opening the driver is optional and will be done implicit by the driver DLL on the first call of any XOnNTX function that accepts a driver handle as input. The driver DLL always remembers the last implicit or explicit opened driver handle and uses this on any other XOnNTX functions called with a NULL-handle (NOT connected handle).
If not explicitly closed using XOnNTX_Close, the driver DLL will close the remembered driver-handle (and only this) on DLL-unload (end of application).
WARNING: To avoid unused opened driver handles (wasting system resources) after end of application, either never use XOnNTX_Open, or balance open calls with calls to XOnNTX_Close.

Connector Pane

Controls and Indicators

cstr IODevice
Optional parameter for future use. Do NOT use it.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle
Handle to the opened driver. Use this an other XOnNTX functions that accept a handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_ReadPort

Reads a single value from the given IO-Port.
You may optionally define the Port-Type Byte, Word or Doubleword (defaults to Byte). In any case the returned value is of type Doubleword.
WARNING: Thus not necessary, using Porttypes other than Byte you should aligne the IOPort appropriatly; 2-Byte for Word-, 4-Byte for Doubleword-Type.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 IOPort
IO-Port to read a Byte, Word or Doubleword from.

For types other than Byte you should aligne the IOPort; 2-Byte for Word-, 4-Byte for Doubleword-Type.

cenum Type(Byte)
Optional porttype, Byte, Word or Doubleword.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 Value
Value read from the given IOPort.

Independently of the give Port-Type always as Doubleword.

idlrn IOHandle/dup
Duplicated Driver-handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_Version

Returns the Driver-Version as string and value.

Connector Pane

Controls and Indicators

istr VersionString

iu32 Version
Low-Word | Minor-Version-Number
High-Word | Major-Version-Number
BIT-31 | Windows-9x Emulation-Flag 0 = Windows-2000/-NT Version 1 = Windows-9x Emulation
BIT-30 | Demo-Flag Full-Demo 0 = NOT a Demo-Version 1 = DEMO-Version
BIT-29 | Demo-Flag HardIO 0 = NOT a Demo-Version 1 = DEMO-Version
BIT-28 | Demo-Flag Shared-Memory 0 = NOT a Demo-Version 1 = DEMO-Version


XOnNTX_WritePort

Writes a single value to the given IO-Port.
You may optionally define the Port-Type Byte, Word or Doubleword (defaults to Byte).

WARNING: Thus not necessary, using Porttypes other than Byte you should aligne the IOPort appropriatly; 2-Byte for Word-, 4-Byte for Doubleword-Type.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-Handle.

cu32 IOPort
IO-Port to write a Byte, Word or Doubleword to.

Types other than Byte requires alignment; 2-Byte for Word-, 4-Byte for Doubleword-Type.

cu32 Value
Value to write.

cenum Type(Byte)
Optional porttype, Byte, Word or Doubleword.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-Handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_DisablePortIO

Disables direct port access in the range from 'PortStart' to 'PortEnd'.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 PortStart
Start port address to disallow direct port access.

cu32 PortEnd
End port address.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_EnablePortIO

Enables direct port access in the range from 'PortStart' to 'PortEnd'.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 PortStart
Start port address to allow direct port access.

cu32 PortEnd
End port address.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_GetPhysAddress

Returns the phys. address associated with the given virtual address.
The virtual address should be mapped via XOnNTX_MapPhysMemory.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 VirtAddr
Virtual start address that should be mapped via XOnNTX_MapPhysMemory.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 PhysAddr
Phys. address associated with the given virtual address. Zero if phys. address is not available for the current process.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_GetPortIOMap

Returns the current Port-IO mapping state for the current process.

Use this function before using XOnNTX_EnablePortIO or XOnNTX_DisablePortIO to save the current mapping state. Use XOnNTX_SetPortIOMap after your direct port access to reset the mapping state.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

i1du8 IOMap
Port mapping state.

WARNING:
As this is an opaque data structure do not modify it's contents. Use the IOMap in calls to XOnNTX_SetPortIOMap only.

idlrn IOHandle/dup
Duplicated Driver-handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_InpB

Reads a single byte value (u8) from the given port via fast direct port access.
WARNING: The given port MUST be in an allowed port-range.
Use XOnNTX_EnablePortIO to enable ports.

Connector Pane

Controls and Indicators

cu16 Port
Port to read the value from.

iu8 Byte
Read value.

iu16 Port/dup
Duplicated port.


XOnNTX_InpD

Reads a single doubleword value (u32) from the given port via fast direct port access.
WARNING: The given port MUST be in an allowed port-range.
Use XOnNTX_EnablePortIO to enable ports.

Connector Pane

Controls and Indicators

cu16 Port
Port to read the value from.

iu32 DWord
Read value.

iu16 Port/dup
Duplicated port.


XOnNTX_InpW

Reads a single word value (u16) from the given port via fast direct port access.
WARNING: The given port MUST be in an allowed port-range.
Use XOnNTX_EnablePortIO to enable ports.

Connector Pane

Controls and Indicators

cu16 Port
Port to read the value from.

iu16 Word
Read value.

iu16 Port/dup
Duplicated port.


XOnNTX_MapPhysMemory

Maps a physical address range into a process specific virtual address range to allow reading/writing directly from/to the memory. You should unmap the memory with XOnNTX_UnmapPhysMemory after using the memory, not to block the virtual address range to long.
Use the utility functions to read/write from/to the virtual address range.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 Length
Nr. of bytes to be mapped.

cu32 PhysAddr
Physical start address to be mapped.

cenum Interface(Isa)
The bus-system over this physical address is accessable.

Mapping the computer-RAM the bus is not necessary. Mapping memory from a board it depends on the bus where board has been plugged in.

cu8 BusNumber(0)
Some computers do have more than one bus of the same type (PCI). In this case you have to select the correct busnr. Your PC-documentation should have information which slot belongs to what busnr.

cenum ReadWrite(RO)
Allowed accesstype.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr
Mapped virtual start address.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_OutB

Writes a single byte value (u8) to the given port via fast direct port access.
WARNING: The given port MUST be in an allowed port-range.
Use XOnNTX_EnablePortIO to enable ports.

Connector Pane

Controls and Indicators

cu16 Port
Port to write the value to.

cu8 Byte(0)
Value to write.

iu16 Port/dup
Duplicated port.


XOnNTX_OutD

Writes a single doubleword value (u32) to the given port via fast direct port access.
WARNING: The given port MUST be in an allowed port-range.
Use XOnNTX_EnablePortIO to enable ports.

Connector Pane

Controls and Indicators

cu16 Port
Port to write the value to.

cu32 DWord
Value to write.

iu16 Port/dup
Duplicated port.


XOnNTX_OutW

Writes a single word value (u16) to the given port via fast direct port access.
WARNING: The given port MUST be in an allowed port-range.
Use XOnNTX_EnablePortIO to enable ports.

Connector Pane

Controls and Indicators

cu16 Port
Port to write the value to.

cu16 Word
Value to write.

iu16 Port/dup
Duplicated port.


XOnNTX_PCICountDevice

Counts nr. of PCI-devices.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu16 VendorID
Vendor-ID of the PCI-device to restrict counting for.

Use xFFFF not to restrict counting.

cu16 DeviceID
Device-ID to restrict the counting for.

Use xFFFF not to restrict counting on any Device-ID.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.

iu32 Devices
Nr. of devices found.


XOnNTX_PCIFindDevice

Find the Bus- and Slot-Number of the specified device.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu16 VendorID
Vendor-ID of PCI-device to find.

Use xFFFF to find devices of any vendor.

cu16 DeviceID
Device-ID of PCI-device to find.

Use xFFFF to find any device.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cu32 Nth(1)
Find the n'th [1..] PCI-device.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.

iu32 BusNo
Busnr. the device has been found.

iu32 SlotNo


XOnNTX_PCIGetConfig

Get configuration of a specific PCI-device.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 BusNo(0)
Busnr. of the CPI-device.

cu32 SlotNo
BIT-description
0..4 | Devicenumber
5..7 | Functionnumber
... | Reserved

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

ccclst PCICfg
Reference notes for PCI configuration fields:

ro | these field are read only. changes to these fields are ignored
ro+ | these field are intended to be read only and should be initialized by the system to their proper values. However, driver may change these settings.

All resources comsumed by a PCI device start as
unitialized under NT. An uninitialized memory or I/O
base address can be determined by checking it's
corrisponding enabled bit in the
PCI_COMMON_CONFIG.Command value.
An InterruptLine is unitialized if it contains the value of
-1.

cu16 VendorID
Vendor-ID // ro

cu16 DeviceID
Device-Id // ro

cu16 Command
Device Control
//
// Bit encodings for PCI_COMMON_CONFIG.Command
//
#define PCI_ENABLE_IO_SPACE                 0x0001
#define PCI_ENABLE_MEMORY_SPACE             0x0002
#define PCI_ENABLE_BUS_MASTER               0x0004
#define PCI_ENABLE_SPECIAL_CYCLES           0x0008
#define PCI_ENABLE_WRITE_AND_INVALIDATE     0x0010
#define PCI_ENABLE_VGA_COMPATIBLE_PALETTE   0x0020
#define PCI_ENABLE_PARITY                   0x0040  // (ro+)
#define PCI_ENABLE_WAIT_CYCLE               0x0080  // (ro+)
#define PCI_ENABLE_SERR                     0x0100  // (ro+)
#define PCI_ENABLE_FAST_BACK_TO_BACK        0x0200  // (ro)

cu16 Status
//
// Bit encodings for PCI_COMMON_CONFIG.Status
//
#define PCI_STATUS_FAST_BACK_TO_BACK        0x0080  // (ro)
#define PCI_STATUS_DATA_PARITY_DETECTED     0x0100
#define PCI_STATUS_DEVSEL                   0x0600  // 2 bits  wide
#define PCI_STATUS_SIGNALED_TARGET_ABORT    0x0800
#define PCI_STATUS_RECEIVED_TARGET_ABORT    0x1000
#define PCI_STATUS_RECEIVED_MASTER_ABORT    0x2000
#define PCI_STATUS_SIGNALED_SYSTEM_ERROR    0x4000
#define PCI_STATUS_DETECTED_PARITY_ERROR    0x8000

cu8 RevID

cu8 ProgIF

cu8 SubCl

cu8 BaseCl

cu8 CacheLS

cu8 LatTim

cu8 HType
//
// Bit encodings for  PCI_COMMON_CONFIG.HeaderType
//
#define PCI_MULTIFUNCTION                   0x80
#define PCI_DEVICE_TYPE                     0x00
#define PCI_BRIDGE_TYPE                     0x01

cu8 BIST

cnclst HEADER_TYPE_0

cu32 BaseAddr1
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr2
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr3
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr4
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr5
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx
x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr6
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 CIS

cu16 SubVenID

cu16 SubSysID

cu32 ROMBaseAddr
// Bit encodes for ROMBaseAddr

x00000001 = PCI_ROMADDRESS_ENABLED

cu32 Res1
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 Res2
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu8 IRQLn

cu8 IRQPin

cu8 MinGr

cu8 MaxLat

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.

icclst PCIConfig
Reference notes for PCI configuration fields:

ro | these field are read only. changes to these fields are ignored
ro+ | these field are intended to be read only and should be initialized by the system to their proper values. However, driver may change these settings.

All resources comsumed by a PCI device start as
unitialized under NT. An uninitialized memory or I/O
base address can be determined by checking it's
corrisponding enabled bit in the
PCI_COMMON_CONFIG.Command value.
An InterruptLine is unitialized if it contains the value of
-1.

iu16 VendorID
Read only.
Identifies the manufacturer of the device.

iu16 DeviceID
Read only.
Identifies the particular device. This value is assigned by the manufacturer.

iu16 Command
Accesses the PCI device's control register. Writing a zero to this register renders the device logically disconnected from the PCI bus except for configuration access. Otherwise, the functionality of the register is device-dependent.
Bit encodings for PCI_COMMON_CONFIG.Command
//
// Bit encodings for PCI_COMMON_CONFIG.Command
//
#define PCI_ENABLE_IO_SPACE                 0x0001
#define PCI_ENABLE_MEMORY_SPACE             0x0002
#define PCI_ENABLE_BUS_MASTER               0x0004
#define PCI_ENABLE_SPECIAL_CYCLES           0x0008
#define PCI_ENABLE_WRITE_AND_INVALIDATE     0x0010
#define PCI_ENABLE_VGA_COMPATIBLE_PALETTE   0x0020
#define PCI_ENABLE_PARITY                   0x0040  // (ro+)
#define PCI_ENABLE_WAIT_CYCLE               0x0080  // (ro+)
#define PCI_ENABLE_SERR                     0x0100  // (ro+)
#define PCI_ENABLE_FAST_BACK_TO_BACK        0x0200  // (ro)
iu16 Status
Accesses the PCI device's status register. The functionality of this register is device-dependent.
Bit encodings for PCI_COMMON_CONFIG.Status

//
// Bit encodings for PCI_COMMON_CONFIG.Status
//
#define PCI_STATUS_FAST_BACK_TO_BACK        0x0080  // (ro)
#define PCI_STATUS_DATA_PARITY_DETECTED     0x0100
#define PCI_STATUS_DEVSEL                   0x0600  // 2 bits  wide
#define PCI_STATUS_SIGNALED_TARGET_ABORT    0x0800
#define PCI_STATUS_RECEIVED_TARGET_ABORT    0x1000
#define PCI_STATUS_RECEIVED_MASTER_ABORT    0x2000
#define PCI_STATUS_SIGNALED_SYSTEM_ERROR    0x4000
#define PCI_STATUS_DETECTED_PARITY_ERROR    0x8000

iu8 RevID
RevisionID
Specifies the revision level of the device described by the DeviceID member. This value is assigned by the manufacturer.

iu8 ProgIF
Identifies the register-level programming interface, if any, for the device, according to the PCI classification scheme.

iu8 SubCl
SubClass
Identifies the subtype, if any, of the device, according to the PCI classification scheme.

iu8 BaseCl
BaseClass
Identifies type of the device, according to the PCI classification scheme.

iu8 CacheLS
CacheLineSize
Contains the system cache line size in 32-bit units. This member is relevant only for PCI busmaster devices. The system determines this value during the boot process.

iu8 LatTim
LatencyTimer
Contains the value of the latency timer in units of PCI bus clocks. This member is relevant only for PCI busmaster devices. The system determines this value during the boot process.

iu8 HType
HeaderType
The system ORs the value of this member with PCI_MULTIFUNCTION, if appropriate to the device. The value of this member indicates the PCI_HEADER_TYPE_0 layout that follows.
Bit encodings for PCI_COMMON_CONFIG.HeaderType

x80 | PCI_MULTIFUNCTION
x00 | PCI_DEVICE_TYPE
x01 | PCI_BRIDGE_TYPE

iu8 BIST
Built In Self Test
Zero indicates that the device does not support built-in self test. Otherwise, the device supports built-in self test according to the PCI standard.

inclst HEADER_TYPE_0

iu32 BaseAddr1
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

iu32 BaseAddr2
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

iu32 BaseAddr3
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

iu32 BaseAddr4
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

iu32 BaseAddr5
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT
iu32 BaseAddr6
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

iu32 CIS

iu16 SubVenID

iu16 SubSysID

iu32 ROMBaseAddr
// Bit encodes for ROMBaseAddr

x00000001 = PCI_ROMADDRESS_ENABLED

iu32 Res1

iu32 Res2

iu8 IRQLn
Interruptline

iu8 IRQPin
Interruptpin

iu8 MinGr
MinimumGrant

iu8 MaxLat
MaximumLatency

i1du8 DevSpecific
Contains any device-specific initialization information that is available.

iu8


XOnNTX_PCISetConfig

Set configuration of a specific PCI-device.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 BusNo(0)
Busnr. of the CPI-device.

cu32 SlotNo
BIT-description
0..4 | Devicenumber
5..7 | Functionnumber
... | Reserved

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

ccclst PCIConfig
Reference notes for PCI configuration fields:

ro | these field are read only. changes to these fields are ignored
ro+ | these field are intended to be read only and should be initialized by the system to their proper values. However, driver may change these settings.

All resources comsumed by a PCI device start as
unitialized under NT. An uninitialized memory or I/O
base address can be determined by checking it's
corrisponding enabled bit in the
PCI_COMMON_CONFIG.Command value.
An InterruptLine is unitialized if it contains the value of
-1.

cu16 VendorID
Read only.
Identifies the manufacturer of the device.

cu16 DeviceID
Read only.
Identifies the particular device. This value is assigned by the manufacturer.

cu16 Command
Accesses the PCI device's control register. Writing a zero to this register renders the device logically disconnected from the PCI bus except for configuration access. Otherwise, the functionality of the register is device-dependent.
Bit encodings for PCI_COMMON_CONFIG.Command

//
// Bit encodings for PCI_COMMON_CONFIG.Command
//
#define PCI_ENABLE_IO_SPACE                 0x0001
#define PCI_ENABLE_MEMORY_SPACE             0x0002
#define PCI_ENABLE_BUS_MASTER               0x0004
#define PCI_ENABLE_SPECIAL_CYCLES           0x0008
#define PCI_ENABLE_WRITE_AND_INVALIDATE     0x0010
#define PCI_ENABLE_VGA_COMPATIBLE_PALETTE   0x0020
#define PCI_ENABLE_PARITY                   0x0040  // (ro+)
#define PCI_ENABLE_WAIT_CYCLE               0x0080  // (ro+)
#define PCI_ENABLE_SERR                     0x0100  // (ro+)
#define PCI_ENABLE_FAST_BACK_TO_BACK        0x0200  // (ro)

cu16 Status
Accesses the PCI device's status register. The functionality of this register is device-dependent.
Bit encodings for PCI_COMMON_CONFIG.Status

//
// Bit encodings for PCI_COMMON_CONFIG.Status
//
#define PCI_STATUS_FAST_BACK_TO_BACK        0x0080  // (ro)
#define PCI_STATUS_DATA_PARITY_DETECTED     0x0100
#define PCI_STATUS_DEVSEL                   0x0600  // 2 bits  wide
#define PCI_STATUS_SIGNALED_TARGET_ABORT    0x0800
#define PCI_STATUS_RECEIVED_TARGET_ABORT    0x1000
#define PCI_STATUS_RECEIVED_MASTER_ABORT    0x2000
#define PCI_STATUS_SIGNALED_SYSTEM_ERROR    0x4000
#define PCI_STATUS_DETECTED_PARITY_ERROR    0x8000

cu8 RevID
RevisionID
Specifies the revision level of the device described by the DeviceID member. This value is assigned by the manufacturer.

cu8 ProgIF
Identifies the register-level programming interface, if any, for the device, according to the PCI classification scheme.

cu8 SubCl
SubClass
Identifies the subtype, if any, of the device, according to the PCI classification scheme.

cu8 BaseCl
BaseClass
Identifies type of the device, according to the PCI classification scheme.

cu8 CacheLS
CacheLineSize
Contains the system cache line size in 32-bit units. This member is relevant only for PCI busmaster devices. The system determines this value during the boot process.

cu8 LatTim
LatencyTimer
Contains the value of the latency timer in units of PCI bus clocks. This member is relevant only for PCI busmaster devices. The system determines this value during the boot process.

cu8 HType
HeaderType
The system ORs the value of this member with PCI_MULTIFUNCTION, if appropriate to the device. The value of this member indicates the PCI_HEADER_TYPE_0 layout that follows.
Bit encodings for PCI_COMMON_CONFIG.HeaderType

x80 | PCI_MULTIFUNCTION
x00 | PCI_DEVICE_TYPE
x01 | PCI_BRIDGE_TYPE

cu8 BIST
Built In Self Test
Zero indicates that the device does not support built-in self test. Otherwise, the device supports built-in self test according to the PCI standard.

cnclst HEADER_TYPE_0

cu32 BaseAddr1
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr2
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr3
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr4
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE |
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr5
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr6
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 CIS

cu16 SubVenID

cu16 SubSysID

cu32 ROMBaseAddr
// Bit encodes for ROMBaseAddr

x00000001 = PCI_ROMADDRESS_ENABLED

cu32 Res1

cu32 Res2

cu8 IRQLn
Interruptline

cu8 IRQPin
Interruptpin

cu8 MinGr
MinimumGrant

cu8 MaxLat
MaximumLatency

c1du8 DevSpecific
Contains any device-specific initialization information that is available.

ccclst PCICfg
Reference notes for PCI configuration fields:

ro | these field are read only. changes to these fields are ignored
ro+ | these field are intended to be read only and should be initialized by the system to their proper values. However, driver may change these settings.

All resources comsumed by a PCI device start as
unitialized under NT. An uninitialized memory or I/O
base address can be determined by checking it's
corrisponding enabled bit in the
PCI_COMMON_CONFIG.Command value.
An InterruptLine is unitialized if it contains the value of
-1.

cu16 VendorID
Vendor-ID // ro

cu16 DeviceID
Device-Id // ro

cu16 Command
Device Control
//
// Bit encodings for PCI_COMMON_CONFIG.Command
//
#define PCI_ENABLE_IO_SPACE                 0x0001
#define PCI_ENABLE_MEMORY_SPACE             0x0002
#define PCI_ENABLE_BUS_MASTER               0x0004
#define PCI_ENABLE_SPECIAL_CYCLES           0x0008
#define PCI_ENABLE_WRITE_AND_INVALIDATE     0x0010
#define PCI_ENABLE_VGA_COMPATIBLE_PALETTE   0x0020
#define PCI_ENABLE_PARITY                   0x0040  // (ro+)
#define PCI_ENABLE_WAIT_CYCLE               0x0080  // (ro+)
#define PCI_ENABLE_SERR                     0x0100  // (ro+)
#define PCI_ENABLE_FAST_BACK_TO_BACK        0x0200  // (ro)

cu16 Status
//
// Bit encodings for PCI_COMMON_CONFIG.Status
//
#define PCI_STATUS_FAST_BACK_TO_BACK        0x0080  // (ro)
#define PCI_STATUS_DATA_PARITY_DETECTED     0x0100
#define PCI_STATUS_DEVSEL                   0x0600  // 2 bits  wide
#define PCI_STATUS_SIGNALED_TARGET_ABORT    0x0800
#define PCI_STATUS_RECEIVED_TARGET_ABORT    0x1000
#define PCI_STATUS_RECEIVED_MASTER_ABORT    0x2000
#define PCI_STATUS_SIGNALED_SYSTEM_ERROR    0x4000
#define PCI_STATUS_DETECTED_PARITY_ERROR    0x8000

cu8 RevID

cu8 ProgIF

cu8 SubCl

cu8 BaseCl

cu8 CacheLS

cu8 LatTim

cu8 HType
//
// Bit encodings for  PCI_COMMON_CONFIG.HeaderType
//
#define PCI_MULTIFUNCTION                   0x80
#define PCI_DEVICE_TYPE                     0x00
#define PCI_BRIDGE_TYPE                     0x01

cu8 BIST

cnclst HEADER_TYPE_0

cu32 BaseAddr1
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr2
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr3
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr4
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT
cu32 BaseAddr5
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 BaseAddr6
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 CIS

cu16 SubVenID

cu16 SubSysID

cu32 ROMBaseAddr
// Bit encodes for ROMBaseAddr

x00000001 = PCI_ROMADDRESS_ENABLED

cu32 Res1
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu32 Res2
Bit encodes for PCI_COMMON_CONFIG.BaseAddrx

x00000001 | PCI_ADDRESS_IO_SPACE | ro
x00000006 | PCI_ADDRESS_MEMORY_TYPE_MASK | ro
x00000008 | PCI_ADDRESS_MEMORY_PREFETCHABLE | ro

0 | PCI_TYPE_32BIT
2 | PCI_TYPE_20BIT
4 | PCI_TYPE_64BIT

cu8 IRQLn

cu8 IRQPin

cu8 MinGr

cu8 MaxLat

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_SetPortIOMap

Resets the Port-IO mapping state of the current process.

Use this function as counterpart to XOnNTX_GetPortIOMap to reset the mapping state. This will revoke all state changes from calls to XOnNTX_EnablePortIO or XOnNTX_DisablePortIO.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

c1du8 IOMap
Port mapping state to set.

WARNING:
Use IOMap's returned from calls to XOnNTX_GetPortIOMap only.

cu8

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_UnmapPhysMemory

Unmaps the physical address range of the given virtual address range. The given start address (VirtAdr) MUST be the result of a mapping operation via XOnNTX_MapPhysMemory.
After unmapping, the virtual address range is no longer allowed to be read or written.

Connector Pane

Controls and Indicators

cdlrn IOHandle
Driver-handle.

cu32 VirtAddr
Virtual start address that has been mapped via XOnNTX_MapPhysMemory.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_CloseSharedMemory

Closes a shared memory object handle. Does not remove the shared memory object if other users of the shared memory exist.

Returns the nr. of users left.

Connector Pane

Controls and Indicators

cdlrn SMemHdl
Handle of an opened shared memory object.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 UsersLeft
Nr. of users left after closing.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_CreateSharedMemory

Creates a new or opens an existing shared memory object (named or unnamed).
Returns a handle to the shared memory object and a virtual address pointer to the shared memory.
Use the utility functions to read/write from/to the shared memory.

Connector Pane

Controls and Indicators

cstr Name
Name of shared-memory object (optional).
Named shared memory objects can be opened from other processes in the system.

cu32 MaxSize
Max. size of the shared memory in bytes.

cbool ReadOnly(F)
True : Create/Open for reading from the shared memory only
False: Create/Open for reading and writing.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cdlrn IOHandle
Driver-handle.

idlrn SMemHdl
Handle to the created/opened shared memory object.

iu32 VirtAddr
Virtual address of the shared memory.

Use this address with the utility functions to access the memory.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_InfoSharedMemory

Returns information on an existing shared memory object.

You may give an open shared memory handle or the name of a shared memory object to ask for information.

Connector Pane

Controls and Indicators

cdlrn SMemHdl

cstr Name
Name of shared-memory object (optional).

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn SMemHdl/dup

icclst SMemInfo
Structure with information on shared memory objects.

istr Name
Name of shared memory object. Empty if unnamed.

iu32 Users
Nr. of users of the shared memory object.

iu32 Size
Max. nr. of bytes the shared memory can hold.

iu32 VirtAddr
Virtual address of the shared memory.

May be zero if shared memory object exists but has not been opened from the current process.

ibool ReadOnly
True : Shared memory object is opened for reading only
False: Shared memory object can be read or written.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_OpenSharedMemory

Opens an existing shared memory object (named or unnamed).
Returns a handle to the shared memory object and a virtual address pointer to the shared memory.
Use the utility functions to read/write from/to the shared memory.

Connector Pane

Controls and Indicators

cstr Name
Name of shared-memory object (optional).
Named shared memory objects can be opened from other processes in the system.

cbool ReadOnly(F)
True : Create/Open for reading from the shared memory only
False: Create/Open for reading and writing.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cdlrn IOHandle
Driver-handle.

cbool Inheritable(T)
True : The shared memory handle can be inherited by newly created
processes.
False: The shared memory object handle cannot be inherited.

idlrn SMemHdl
Handle to the opened shared memory object.

iu32 VirtAddr
Virtual address of the shared memory.

Use this address with the utility functions to access the memory.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_SMRBufClear

Clears the ring-buffer.

Connector Pane

Controls and Indicators

cdlrn SMRBuf
Handle of a ring-buffer.
XOnNTX_SMRBufCreate or XOnNTX_SMRBufOpen returns this handle.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cbool ResWrtCnt(T)
True : Reset write-counter to zero.
False: Do not reset the write-counter

The write-counter counts the nr. of bytes ever written to the buffer.

idlrn SMRBuf/dup
Duplicated ring-buffer handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_SMRBufClose

Closes an open ring-buffer.
Closing a ring-buffer removes the buffer only if it is the last process that uses the buffer. If not, the buffer-contents will be kept and only administration structures are cleared.

Connector Pane

Controls and Indicators

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cdlrn SMRBuf
Handle of a ring-buffer.
XOnNTX_SMRBufCreate or XOnNTX_SMRBufOpen returns this handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_SMRBufCreate

Creates a new or opens an existing ring-buffer based on shared memory. Returns a handle to the ring-buffer.

Connector Pane

Controls and Indicators

cstr Name
Name of ring-buffer (optional).
Named ring-buffers can be opened from other processes in the system.

cu32 BufSize
Size in bytes the ring-buffer can hold.
The size will be internally aligned according to the 'Align' parameter.

cenum EvtMode(No)
Eventmode.
On Eventmodes other than 'NoEvt' the ring-buffer administration creates a named Read- and/or Write-Eventobject that may be used to synchronize read- and write-operations.
A read-event will be signaled if any ring-buffer user reads data or clears the ring-buffer.
A write-event will be signaled on write-operations.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cdlrn IOHandle
Driver-handle.

cu32 Align(1)
Alignment of the ring-buffer.
The ring-buffer administration forces sizes on read-/write-operations to be aligned according to this parameter.

Example: If buffer should hold only 32-BIT integers set 'Align' to 4
(the byte size of int32)

cu32 MtxWaitMS(10)
Mutexwait Timeout (optional).
The buffer administration always creates a named mutex-object for a ring-buffer. It is used to synchronize the access to internal structures for parallel processes. While one process is reading or writing to the buffer other processes wait on this mutex-object.
The 'MtxWaitMS' parameter sets the timeout value in milliseconds for this wait-operation.
If a wait timed out on a read or write, the function will return an error.

idlrn SMRBuf
Handle of the new or opened shared memory based ring-buffer.
Use this handle with other XOnNTX_SMRB.. functions.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_SMRBufInfo

Returns informations on a ring-buffer.

Connector Pane

Controls and Indicators

cdlrn SMRBuf
Handle of a ring-buffer.
XOnNTX_SMRBufCreate or XOnNTX_SMRBufOpen returns this handle.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn SMRBuf/dup
Duplicated ring-buffer handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

icclst SMRBufInfo
Ring-buffer info structure.

iu32 Align
Current buffer alignment in bytes.

iu32 WrtCount
Nr. of bytes ever written to the ring-buffer.

iu32 BufSize
Max. nr. of bytes the buffer can hold.

iu32 Overrun
Nr. of overrun-bytes.

iu32 ReadAvail
Nr. of bytes currently available for read-operations.

iu32 WriteAvail
Nr. of bytes currently free for write-operations.

idlrn SMemHdl
Handle of the shared-memory object the ring-buffer is based on.

WARNING:
You should NOT write directly to the shared memory.This destroys administration structures and will lead to errors and/or system-crashes.

iu32 hMutex
Handle of the mutex-object internally used to synchronize buffer-access.

iu32 hReadEvt
Handle of the read-event-object that will be signaled on read-operations (may be 0 if not created).
WARNING: Use this handle only for wait-operations.

iu32 hWriteEvt
Handle of the write-event-object that will be signaled on write-operations (may be 0 if not created).
WARNING: Use this handle only for wait-operations.

istr Mutex
Name of mutex object.

istr ReadEvt
Name of read-event-object. May be empty if not created.

istr WriteEvt
Name of write-event-object. May be empty if not created.


XOnNTX_SMRBufOpen

Opens an existing ring-buffer (named or unnamed).
Returns an error if ring-buffer could not be opened (does not exist).

Connector Pane

Controls and Indicators

cstr Name
Name of existing ring-buffer (optional).
Unnamed ring-buffers must be created by the same process to be opened by this functions. Named ring-buffers can be created by other processes in the system.

cenum EvtMode(No)
Eventmode.
On Eventmodes other than 'NoEvt' the ring-buffer administration creates a named Read- and/or Write-Eventobject that may be used to synchronize read- and write-operations.
A read-event will be signaled if any ring-buffer user reads data or clears the ring-buffer.
A write-event will be signaled on write-operations.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cdlrn IOHandle
Driver-handle.

cu32 MtxWaitMS(10)
Mutexwait Timeout (optional).
The buffer administration always creates a named mutex-object for a ring-buffer. It is used to synchronize the access to internal structures for parallel processes. While one process is reading or writing to the buffer other processes wait on this mutex-object.
The 'MtxWaitMS' parameter sets the timeout value in milliseconds for this wait-operation.
If a wait timed out on a read or write, the function will return an error.

idlrn SMRBuf
Handle of the opened shared memory based ring-buffer.
Use this handle with other XOnNTX_SMRB.. functions.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

idlrn IOHandle/dup
Duplicated Driver-handle.


XOnNTX_SMRBufRead

Reads up to 'MaxSize' bytes from the ring-buffer.
The function does not wait until enough data are in the buffer. If less then 'MaxSize' bytes are available only the entire buffer contents will be returned.

Connector Pane

Controls and Indicators

cdlrn SMRBuf
Handle of a ring-buffer.
XOnNTX_SMRBufCreate or XOnNTX_SMRBufOpen returns this handle.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cu32 MaxSize
Max. nr. of bytes to be read from the ring-buffer.

idlrn SMRBuf/dup
Duplicated ring-buffer handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

istr Data/raw
Read data in raw-format.

iu32 Overrun
Nr. of overrun-bytes since last read operation.


XOnNTX_SMRBufReadEx

Reads up to 'MaxSize' bytes from the ring-buffer.
The function waits upto 'WaitMS' milliseconds until enough data is in the buffer. If the wait timed out only the entire buffer-contents will be returned.
While waiting, the function allowes write-operations from other processes (threads). This allowes to read more data as the ring-buffer can hold.

Connector Pane

Controls and Indicators

cdlrn SMRBuf
Handle of a ring-buffer.
XOnNTX_SMRBufCreate or XOnNTX_SMRBufOpen returns this handle.

cu32 WaitMS(0)
Max. nr. of milliseconds to wait until enough data are in the buffer.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cu32 MaxSize
Max. nr. of bytes to be read from the ring-buffer.

idlrn SMRBuf/dup
Duplicated ring-buffer handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

istr Data/raw
Read data in raw-format.

iu32 Overrun
Nr. of overrun-bytes since last read operation.


XOnNTX_SMRBufWrite

Writes (appends) data into the ring-buffer.
The function will overwrite existing data if not enough free space is available. The function does not write more than the max. size the buffer can hold.

Connector Pane

Controls and Indicators

cdlrn SMRBuf
Handle of a ring-buffer.
XOnNTX_SMRBufCreate or XOnNTX_SMRBufOpen returns this handle.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cstr Data/raw
Data in raw format to write.

idlrn SMRBuf/dup
Duplicated ring-buffer handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 Written
Nr. of bytes written.


XOnNTX_SMRBufWriteEx

Writes (appends) data into the ring-buffer.
The function waites up to 'WaitMS' milliseconds until enough space is available to write the data.
While waiting, the function allowes read-operations from other processes (threads). This allowes to write more data than the ring-buffer can hold.

Connector Pane

Controls and Indicators

cdlrn SMRBuf
Handle of a ring-buffer.
XOnNTX_SMRBufCreate or XOnNTX_SMRBufOpen returns this handle.

cu32 WaitMS(0)
Max. nr. of milliseconds to wait until enough free space is available.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cstr Data/raw
Data in raw format to write.

idlrn SMRBuf/dup
Duplicated ring-buffer handle.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 Written
Nr. of bytes written.


XOnNTX_MoveMemory

Connector Pane

Controls and Indicators

cu32 DstAddr

cu32 SrcAddr

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cu32 Length

iu32 DstAddr/dup

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 SrcAddr/dup


XOnNTX_ReadByte

Read a byte (u8) from given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated virtual address.

iu8 Byte
Read value.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_ReadDWord

Read a doubleword (u32) from given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated virtual address.

iu32 DWord
Read value.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_ReadMemory

Read 'Length' bytes starting at given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

cu32 Length
Nr. of bytes to read.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated start address.

istr Data
Read data.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_ReadString

Read a string of max. length 'MaxLen' starting at given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

cu32 MaxLen(1024)
Max. stringlength.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated virtual address.

istr Data
Read string.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_ReadWord

Read a word (u16) from given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated virtual address.

iu16 Word
Read value.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_WriteByte

Write a byte (u8) to the given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

cu8 Byte(0)
Value to write.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated virtual address.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_WriteDWord

Write a doubleword (u32) to the given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

cu32 DWord(0)
Value to write.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated virtual address.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_WriteMemory

Writes data to the given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

cstr Data
Data to write.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated start address.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_WriteString

Write string 'Data' to the given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

cstr Data
String to write.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated start address.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


XOnNTX_WriteWord

Write a word (u16) to the given virtual address.

Connector Pane

Controls and Indicators

cu32 VirtAddr
Virtual start address.

cu16 Word(0)
Value to write.

ccclst error in (no error)
error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

cbool status
status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ci32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

cstr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iu32 VirtAddr/dup
Duplicated virtual address.

icclst error out
error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

ibool status
status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

ii32 code
code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

istr source
source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.


PCI_COMMON_CONFIG

Connector Pane


PCI_CONFIG

Connector Pane


IOHANDLE

Connector Pane

iohandlec


XONNTX_DIAGINFO

Connector Pane


SMEMHDL

Handle of shared memory.

Connector Pane

smemhdlc


SMEMINFO

Infostructure for inforamtion on shared memory objects.

Connector Pane

smeminfoc


SMRBUFHDL

Handle of a shared memory based ring-buffer.

Connector Pane

smrbufhdlc


SMRBUFINFO

Ring-Buffer info.

Connector Pane

smrbufinfoc


Contact

xon-logo
XOn Software GmbH
Luisenstraße 43
80333 München
Telefon: +49 (0)89/542716-0
Telefax: +49 (0)89/542716-78
E-mail: info@xon.de
Internet: http://www.xon.de

Your partner for ...
LabVIEW, LabWindows/CVI, Microsoft Visual C++, National Instruments Hardware, GPIB, CAN, Profibus, RS232, RS 485...